• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
every now and again SDK becomes unusable...
Further to this, i think I've identified a source of issues i was encountering - nothing to do with the issues above. But sadly still doesn't fix the issues i'm having.

I had cloned a project (keys + data) for testing purposes with the new SDK, downloaded the new SDK etc.
However it wasn't finding the cdbUsers table (the cdb_userTableName was just returning cdbUsers-, without the UUID that used to follow after the hyphen).

I recreated a new project from scratch and imported the existing data after exporting to JSON - that seems to fix this.
So the issue seems to be that associated with cloning a project - something is buggy behind the scenes.

Having said that, i'm still informed in the message output that the authentication key has changed (why?? this is a 'fresh' copied from the export SDK screen and this occurs on immediately running the app 1st time) and that a new key has been requested, but then end up with 'error reading cloud records'.

It is very likely 'i'm not doing it right' but i'm currently not able to use LiveCloud at all with the new SDK.

My set up at present is all initialisation scripts are the mainStack script, being called from an On PreOpenStack handler on the 1st card of the mainStack and this is being run in the IDE, not standalone). The scripts are copied directly from the 'export SDK' screen with one minor amendment as put the canelaDB folder in a subfolder of my 'Documents' folder as a writeable location.

On a related note, there appears to be a further bug in the new version: 
In the 'download SDK' screen, if i click Create project it just creates a folder with the project name that only contains one empty folder "canelaDB" and no files whatsoever. 
This used to generate a sample project with a login screen, but this doesn't happen at present (i thought maybe this had been updated with the new cdb_AutoSetupAuthKey and was keen to see an example).

As it stands at present i can only get my app to work by reverting to an older SDK & script that worked prior to the new version. 

Grateful for any suggestions to fix this unhappy state of affairs...

Messages In This Thread
RE: every now and again SDK becomes unusable... - by stamatis - 06-06-2021, 11:00 AM

Forum Jump:

Users browsing this thread: 1 Guest(s)