• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows OS problems

So we're developing mobile apps for both IOS and Android, they are working well, and an application that should run on both Mac and Windows.

On Mac it works well both in development and compiled.

On Windows it gives "The Canela SDK missing. Please export your CandelaDB again" if stack opened in Livecode Business 5.1.

If compiled to a Windows version from Mac, it doesn't work / download data, so no luck there. *CORRECTED: It does work But i tried to log in with a user created in Mac, and I don't think password hash matched. I will try to create new user from the Windows application instead.

I've tried several things. Among them to export the toolkit from a LiveCloud Manager that runs on Windows, in case of encryption being different or something. 

As your stacks are encrypted, and encryption results can be different between platforms, could that be the issue here? 

Something is wrong in any case ....

Br /John
Hi John,

All platforms are compatible with the same CanelaDB folder that is exported from LCM. The main thing to keep in mind for Windows and Linux is the placement of the CanelaDB folder. The libraries are having trouble finding the Config file. Our provided initializeCanelaDB code may not match the actual location of the CanelaDB folder.

It is just fine to put the CanelaDB folder where you like. We default it to being at the same level as your executable. If this is not the case, simply update the path in the initializeCanelaDB handler to the actual path of the CanelaDB folder.

You should look at this section of the init handler (paying attention to the case "Win32":

switch the platform
               case "android"
               case "iPhone"
                    put specialFolderPath("engine") & "/CanelaDB/libraries/" into tLibraryPath
               case "MacOS"
                    put specialFolderPath("resources") & "/CanelaDB/libraries/" into tLibraryPath
               case "Win32"
               case "Linux"
                    put item 1 to -2 of (the fileName of this stack) into tLibraryPath
                    put "/CanelaDB/libraries/" after tLibraryPath
end switch

I forgot to update this issue that's not an issue for me anymore, except that it occurs only in a virtual Win10 running in Parallels Desktop on Mac.

I have not tried to solve it there, I just used another virtual machine on Paperspace instead and everything works fine.

Maybe it's something with Parallels Desktop, or it's configuration, or that I just have to reinstall Livecode... I'll let you know if I find a solution. Unless you already know why :-) 

Hi John,

Your experience with Parallels is not expected behavior. I personally use Parallels for Windows development. Others on the team use Vmware, VirtualBox, and Windows only hardware. I would try exporting the toolkit again and the init code that LCM provides.

Please check the following:
- In your LiveCode stack, please check that you do not have more than one copy of the init handlers.
- If you are sharing the preOpenStack, could something in the code interrupt running the initCanelaDB code?

For the benefit of others, we now have a video that shows how to export the toolKit. I am confident you have this down based on your positive experiences.

Forum Jump:

Users browsing this thread: 1 Guest(s)