• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Weird LCM crash/hang at startup
Ok this hasn't happened before: 

I launch LCM and am first greeted with a missing SDK message in LCM. 
Then it tries to log in without me entering any text and it just hangs indefinitely - but can be quit/exited normally...

easier to show a video of it:
[Image: file]

any suggestions?
I removed every trace of LCM (including prefs etc) and re-downloaded a new version. Works fine now.

There had been no change on my end otherwise, so i presume either there was some kind of file corruption or there was an update that didn't go well...

Best regards
Please try downloading and installing LiveCloud Manager again here: https://livecloud.io/get-started/
(09-16-2020, 04:07 PM)Linda Lu Wrote: Please try downloading and installing LiveCloud Manager again here: https://livecloud.io/get-started/

Well, i had already done that - and it worked for a while.

After a few days of working on other stuff i reopened LCM to add a key to series of table - after the 3rd table it starting behaving really weirdly (showing a ton of empty columns/keys and throwing errors). 

I quit LCM and on restarting, i have encountered the very same error again. I will re-download again, but there is something funky going on...

EDIT: This is now reproducibly happening every time i add a key to a table. 
It resolves with reinstalling - inasmuch as i can log in and load the tables again. 
But now every 1-2 tables i add a key to i get this issue.

(The database i'm editing has about 35 tables with 16-18 fields each; the modification is adding a field called "date" the the majority of tables - the database is empty, i'm testing the schema only).

Grateful for any other advice - i can't keep deleting and reinstalling LCM every time i add a key...
Further to this, this is so reproducible now i was easily able to make a video of the error. This now happens every single time i try to add the key as above.

If i delete LiveCloud Manager and re-install it, the newly added key is present; but if i try to add another key this all happens again...

video (Youtube - unlisted, so you need this link to access):

Weirder still:

The above bug remains reproducible. However I've accidentally found out that the username/password fields are still useable in spite the deactivated appearance.
Trying to log in by typing text in user/pass and hitting enter now generates an error that the server is offline. On quitting and restarting it generates new error.

I'm hoping this will make sense to the team and will help them pin down the issue:
Type: Chunk: error in object expression
Object: card 'login' of stack '/Applications/LiveCloudManager.app/Contents/Resources/_MacOS/data/LCM'
Line: dispatch function 'fetchSecureInfo' to stack 'dev tools'
Line Num: 518
Hint: createServerList

Youtube (unlisted) video - click on the youtube logo to view full-size.
(and yes, it still says it's missing it's sdk, i accidentally snipped that out when shortening the video and removed some of the wait to restart LCM):

Further to this, these problems seem to be isolated to the London/UK servers. 

I deleted my account and re-created it on the London severs and still have the same problems. 

However I also created an account on the New York server and it was incredibly smooth and error-free. 

Unfortunately due to restrictions by UK healthcare, I am not permitted to use US servers for any real work, so I’m hoping the team can address these issues which (for me at least) appear to be isolated to the UK servers.
That is very interesting. Would you trying pinging the NY region the same way you did the London region and post your results here?
Hi Mark and Efrain - thank once again for resolving this issue which was due to an unusual set of conditions specific to these servers.
Happy to test the pings if you still need - but i'm guessing there is no longer a need to do so now!

Forum Jump:

Users browsing this thread: 2 Guest(s)